Foreman not launching Webpack on M1 Mac

Tom Iwaniec
I feel like I'm most of the way towards getting my project to work on an M1 Mac Mini, but right now I'm stuck where foreman won't launch webpack even though it's in the Profile.dev. I've tested the same project and it works fine on an Intel mac, but I'm not seeing any errors, it just won't launch Webpack which causes the app to give "Webpacker can't find application.css in..." for every page.

Any ideas?
John Quarto-vonTivadar
i switched to Overmind, which basically does the same thing, and everything was good to go
Tom Iwaniec
Thanks, Overmind looks interesting but still seems like Webpack dev server won't launch so I think it's an issue with Webpack actually. 
Tom Iwaniec
Among many other things I may or may not have done while tinkering trying to get a couple projects running on my M1, the final step that seems to have solved everything was found on StackOverflow. This really seemed to help get my Jumpstart app finally working on the M1 setup:

  1. Deleting the node_module folder, package-lock.json and yarn.lock
  2. In my package.json, I upgraded rails/webpacker: 5.3.0.
  3. I then re-ran yarn install.
  4. Then I ran yarn add node-sass

After that everything was working and there were just a few warnings/errors that needed to be fixed.
Notifications
You’re not receiving notifications from this thread.
Subscribe
© 2021 GoRails, LLC