anyone using a M1 mac?

John Quarto-vonTivadar
Bundler question: On my new M1 I cloned my project's repo and worked on some stuff, including adding a gem. After bundle update I now have a /vendors dir in my app, which was never there before, with reference to both bundle/ruby/2.7.0/... and bundle/ruby/3.0.0/... all related to gems coming from JSP.

confused by this. I read this only happens if you do bundle package which I did not do (not even sure what it does exactly). Is this new Ruby 3.0 behavior? Do i care that that's there now? (but, it's not on my Intel laptop)? Is it related to M1? Is it related to M1 and rbenv?  I don't understand what's going on so it's tricky to come up with a decent Google search to look for an answer
I want to try an M1 soon but am still deterred by all the posts I see re some default-ruby issues, and even more related to Docker not quite being "there" yet. 

But this particular issue, if you run `bundle env` does the first section give any clues if you compare the output for your M1 vs your Intel mac?

Specifically the parts with full paths? Wondering if perhaps on your M1 the default bundler env is using a working-directory relative path? 

Just a wild guess.

  $ bundle env
## Environment
```Bundler             2.2.16
  Platforms         ruby, x86_64-darwin-19
Ruby                3.0.1p64 (2021-04-05 revision 0fb782ee38ea37fd5fe8b1f775f8ad866a82a3f0) [x86_64-darwin19]
  Full Path         /Users/xxxxxxxx/.rvm/rubies/ruby-3.0.1/bin/ruby
  Config Dir        /Users/xxxxxxxx/.rvm/rubies/ruby-3.0.1/etc
RubyGems            3.2.15
  Gem Home          /Users/xxxxxxxx/.rvm/gems/ruby-3.0.1
  Gem Path          /Users/xxxxxxxx/.rvm/gems/ruby-3.0.1:/Users/xxxxxxxx/.rvm/rubies/ruby-3.0.1/lib/ruby/gems/3.0.0
  User Home         /Users/xxxxxxxx
  User Path         /Users/xxxxxxxx/.gem/ruby/3.0.0
  Bin Dir           /Users/xxxxxxxx/.rvm/gems/ruby-3.0.1/bin
Tools               
  Git               2.31.1
  RVM               1.29.12 (latest)
  rbenv             not installed
  chruby            not installed
  rubygems-bundler  (1.4.5)
```

## Bundler Build Metadata

```
Built At          2021-04-09
Git SHA           3d7bfaff25
Released Version  true
```

Notifications
You’re not receiving notifications from this thread.
Subscribe
© 2021 GoRails, LLC