(node:97110) [ENOENT] Error Plugin: heroku: ENOENT: no such file or directory, rename...

I'm still new to Rails. Can anyone tell me what this is and how to get rid of it? I uploaded a brand new Jumpstart repo to heroku. I didn't do anything to it except add Master_Key to Heroku. Is this a Jumpstart error or something else?

Here is the full error:
(node:97110) [ENOENT] Error Plugin: heroku: ENOENT: no such file or directory, rename '/Users/xxx/.config/heroku/config.json' -> '/Users/xxx/.local/share/heroku/config.json'
Use Heroku a lot, never saw that, sorry. But what method did you use to "upload" JSP?

While there are alternatives, the "bulletproof" Heroku way seems to be to 
  1. get JSP working locally, then 
  2. use "git push" to a git remote pointed to Heroku.

The only issue I ran into (so far) getting it to work on Heroku was the (undocumented) need to double up the redis workers as detailed here:

https://jumpstartrails.com/discussions/767

I followed the JSP tutorial exactly after cloning it from GitHub. It works fine locally. It's just when I "git push heroku master" I now have that error. I've looked it up on stackoverflow, etc and there are similar questions with no answers or answers that don't work. Some answers have you updated some items that then totally break JSP. So who knows now.
did you add MASTER_KEY (not Master_Key) to the Settings section of the Heroku app? (Gotta be all caps AFAIK. And that would certainly mess things up if rails is unable to decrypt credentials due to missing MASTER_KEY.)
Yes I did add MASTER_KEY.
It looks like the error comes up upon creation, "heroku create":
Creating app... ⣾ 
(node:28987) [ENOENT] Error Plugin: heroku: ENOENT: no such file or directory, rename '/Users/xxxx/.config/heroku/config.json' -> '/Users/xxxx/.local/share/heroku/config.json'
module: @oclif/[email protected]
task: runHook prerun
plugin: heroku
root: /usr/local/Cellar/heroku/7.54.1/libexec
John Quarto-vonTivadar
did you create a Procfile?  it has to be named exactly that, so a lot of folks also keep another one around Procfile.dev to use during development.  it's where you'd fire up your web worker and sidekiq server on Heroku, and locally where you'd fire up those plus guard,  stripe webhook listener, webpack-dev-server, that sort of stuff.  

also i know this sounds obvious but did you set up heroku as a git remote ? 
So I resolved the [ENOENT] issue by creating the directory that wasn't there, which is what it told me from the beginning: 
(node:28987) [ENOENT] Error Plugin: heroku: ENOENT: no such file or directory, rename '/Users/xxxx/.config/heroku/config.json' -> '/Users/xxxx/.local/share/heroku/config.json'

Really the problems I ran into were from trying too many suggestions on StackOverFlow that weren't exactly my same issue. If I had looked closer at the answer I was given it would have saved me a lot of time. Live and learn!

One other issue that came up after this was resolved. I had used "MASTER_KEY" in the Heroku settings variables but I got this error when pushing and needed to change it to "RAILS_MASTER_KEY" for it to work.

remote: -----> Preparing app for Rails asset pipeline
remote:        Running: rake assets:precompile
remote:        Missing encryption key to decrypt file with. Ask your team for your master key and write it to /tmp/build_d13b4f2c/config/credentials/production.key or put it in the ENV['RAILS_MASTER_KEY'].
remote: 
remote:  !
remote:  !     Precompiling assets failed.

But I have a previous JSP build from a month ago that worked with just "MASTER_KEY" in the heroku settings variables. Anyone else had this happen?
Notifications
You’re not receiving notifications from this thread.
Subscribe
© 2021 GoRails, LLC