We've moved discussions to Discord

api_key_expired in stripe.

Bryan Stewart
So I am getting an auth failure when i run bin/dev now. I am not seeing where the referenced key is. I doublechecked my test keys and reposted them in my development credentials file. Still no joy. I even rolled my keys in stripe. Anyone else all of a sudden seeing this>?
etting ready... [Mon, 11 Apr 2022 15:55:22 EDT] FATAL Error while authenticating with Stripe: Authorization failed, status=401, body={stripe |   "error": {stripe |     "code": "api_key_expired",stripe |     "doc_url": "https://stripe.com/docs/error-codes/api-key-expired",stripe |     "message": "Expired API Key provided: rk_test_*********************************************************************************************m03Kn2",stripe |     "type": "invalid_request_error"stripe |   }stripe | }
Richard Low
Hey Bryan

In terminal: stripe login

I had the same thing last week... The CLI cycles the keys every so often 60-90 days :shrug: and it need to be refreshed by login. It's a security feature.

Richard Low
You’re not receiving notifications from this thread.