We've moved discussions to Discord

Overmind issue in Dev

Mark Nelson
Running bin/dev with Overmind installed on new Rails 7 build results in the following (bundle install does not fix this of course):

$ bin/dev
system | Tmux socket name: overmind-ritual-moon-r0SAdTTxybBFwcZ8kwEj3P
system | Tmux session ID: ritual-moon
system | Listening at ./.overmind.sock
css    | Started with pid 14988...
js     | Started with pid 14989...
web    | Started with pid 14987...
yarn run v1.22.17
yarn run v1.22.17
$ tailwindcss --postcss -i ./app/assets/stylesheets/application.tailwind.css -o ./app/assets/builds/application.css --watch
$ node esbuild.config.js --watch

web    | https://github.com/excid3/jbuilder.git (at partial-paths@394014a) is not yet checked out. Run `bundle install` first.

web    | Exited
css    | Interrupting...
js     | Interrupting...
js     | Exited
css    | Exited
Matthias Orgler
This wasn't a problem for me. I saw the same message when running `bin/setup`, but then the setup script just went ahead and did the necessary `bundle install`.

Did you try to run `bin/setup` first? I also use `overmind s` to start my local server – did you try that as well?
Mark Nelson
Yes, did that initially. Tried reinstall and still same issue. back to rails s for now.
Matthias Orgler
I had issues with hot reloading, but that doesn't seem to be your issue (nevertheless turning it off could be worth a try).

From now on I can only guess. Do you have an internet connection going while starting (because it seems to be needing the excid3/jbuilder git repo)? Or did you modify anything in esbuild.config.js? What if you comment the jbuilder out in your Gemfile – do the other gems with a repo download (like annotate) work or will they produce the same error?

Sorry I cannot provide more thorough help. But I know how frustrating struggling with basic setup stuff can be (I'm also playing around with my new JSP license right now :P).
I've been using foreman (instead of overmind) without issue so far, on a new JSP project. Still more convenient than `rails s` unless you need the tmux stuff that overmind provides..
Mark Nelson
I think this may be related to the jbuilder branch being used as there is also a problem with the generator when creating a resource:

invoke  active_record
      create    db/migrate/20220105034012_create_lists.rb
      create    app/models/list.rb
      invoke    test_unit
      create      test/models/list_test.rb
      create      test/fixtures/lists.yml
      invoke  controller
      create    app/controllers/lists_controller.rb
       error    erb [not found]
Mark Nelson
The issue with foreman is that is seems to create issues with the Heroku deploy, which is why I wanted to use Overmind. Thanks for the helpful comments.
Good to know . I am deploying to Heroku with foreman without issues, so far. So far, but we'll see :)
Mark Nelson
The Overmind issue I was seeing has been resolved in latest merge of JSP master.
Mark Nelson
Running bin/dev with Overmind installed on new Rails 7 build results in the following (bundle install does not fix this of course):

$ bin/dev
system | Tmux socket name: overmind-ritual-moon-r0SAdTTxybBFwcZ8kwEj3P
system | Tmux session ID: ritual-moon
system | Listening at ./.overmind.sock
css    | Started with pid 14988...
js     | Started with pid 14989...
web    | Started with pid 14987...
yarn run v1.22.17
yarn run v1.22.17
$ tailwindcss --postcss -i ./app/assets/stylesheets/application.tailwind.css -o ./app/assets/builds/application.css --watch
$ node esbuild.config.js --watch

web    | https://github.com/excid3/jbuilder.git (at partial-paths@394014a) is not yet checked out. Run `bundle install` first.

web    | Exited
css    | Interrupting...
js     | Interrupting...
js     | Exited
css    | Exited
Matthias Orgler
This wasn't a problem for me. I saw the same message when running `bin/setup`, but then the setup script just went ahead and did the necessary `bundle install`.

Did you try to run `bin/setup` first? I also use `overmind s` to start my local server – did you try that as well?
Mark Nelson
Yes, did that initially. Tried reinstall and still same issue. back to rails s for now.
Matthias Orgler
I had issues with hot reloading, but that doesn't seem to be your issue (nevertheless turning it off could be worth a try).

From now on I can only guess. Do you have an internet connection going while starting (because it seems to be needing the excid3/jbuilder git repo)? Or did you modify anything in esbuild.config.js? What if you comment the jbuilder out in your Gemfile – do the other gems with a repo download (like annotate) work or will they produce the same error?

Sorry I cannot provide more thorough help. But I know how frustrating struggling with basic setup stuff can be (I'm also playing around with my new JSP license right now :P).
I've been using foreman (instead of overmind) without issue so far, on a new JSP project. Still more convenient than `rails s` unless you need the tmux stuff that overmind provides..
Mark Nelson
I think this may be related to the jbuilder branch being used as there is also a problem with the generator when creating a resource:

invoke  active_record
      create    db/migrate/20220105034012_create_lists.rb
      create    app/models/list.rb
      invoke    test_unit
      create      test/models/list_test.rb
      create      test/fixtures/lists.yml
      invoke  controller
      create    app/controllers/lists_controller.rb
       error    erb [not found]
Mark Nelson
The issue with foreman is that is seems to create issues with the Heroku deploy, which is why I wanted to use Overmind. Thanks for the helpful comments.
Good to know . I am deploying to Heroku with foreman without issues, so far. So far, but we'll see :)
Mark Nelson
The Overmind issue I was seeing has been resolved in latest merge of JSP master.
Notifications
You’re not receiving notifications from this thread.
© 2022 Jumpstart Pro by GoRails, LLC