Server Stall Out

Dan Tappin
I have the default stock JSPRO installed and just playing around to configure it.  Started this via the README instructions using foreman.

Now the app seems to randomly timeout (endless loading) and I have to restart foreman each time.  Am I missing something here?
John Quarto-vonTivadar
i get this too!!  It more noticeable since I upgraded to from Ruby 2.7.2 -> 2.7.3 and to Rails 6.0.3.6
Brad Halstead
I have been getting this too...
Dan Tappin
It's getting worse.  The app responds but the terminal logs stop updating.  Kind of hard to troubleshoot  Turbo links calls failing when you can't see the remote calls in the logs.  Also when I quit foreman to restart my CLI goes 'blank'.  If I 'arrow-up' for my last command (foreman start) the CLI doesn't update.  If I hit enter or type any commands they run but I am literally typing blind.
John Quarto-vonTivadar
yes, same here. And yes, definitely more often now.    I'm wondering if it's related in some way to newer versions of foreman or rails , or if you're on a Mac, even the new update of the OS 11.3.1
Chris Oliver
First off, all forms are handled by Hotwire now, so if you make a request and it fails with an error, you may not see that error reflected in the browser. I think that's a bug in Turbo.js that needs fixing on the fetch request.

Also, give Overmind a try instead of Foreman. It might handle things better. And of course, run the Rails server directly and see if it still happens.

I've noticed some weirdness where I can't Ctrl-C a Rails server lately. I have to kill it manually. Not sure what causes that. 
John Quarto-vonTivadar
definitely going to try Overmind, thanks for that pointer.   When i run Rails, and node and sidekiq each in their own terminal windows everything works flawlessly.

also, in re: Hotwire....is this something that would have gotten picked up from a gem update or would we have had to fetch and merge the latest JSP?
John Quarto-vonTivadar
Overmind took 3 min to read up on and install and solved whatever issue Foreman was having immediately.   I have a different Procfile for dev vs prod so I do :
`overmind start -f Procfile.dev`
Notifications
You’re not receiving notifications from this thread.
© 2022 GoRails, LLC