User Model or Module?

Ayo Amadi
Rails doesn't know what to do with the module User and the obvious model User having the same name.

/app/app/models/user/connected_account.rb:32:in `<main>': User is not a module (TypeError)
/app/app/models/user.rb:46: previous definition of User was here
Alan Matthews
This is a namespace collision.  You'll need to rename the module to something so it won't conflict with the existing User model.
Ayo Amadi
I'm aware of what the issue is. My problem is that there were several issues with this coming from jumpstart pro out of the box. Thanks for your response :))
is this a current issue still?
Khaled Bentoumi
Yes, I just setup the jumpstart pro out of the box and I'm facing this same issue  JPW  
Khaled Bentoumi when does the error occur... I'm just setting it up for the first time now, haven't seen it yet...
Khaled Bentoumi
I'm only having the error when I run the test
Richard Low
@Khaled Bentoumi were you able to get a fix? I am out of the box and facing this issue when I run db:migrate 
Richard Low
**UPDATE FIX**

The annotate GEM was a bit broken... for the time being I have commented mine out 
Notifications
You’re not receiving notifications from this thread.
Subscribe
© 2022 GoRails, LLC